Loserkidzz

Story Of a Lonely Guy.. :) II Mencoba meninggalkan kebaikan, karna waktu begitu cepat berlalu

Category Archives: Computer

Cisco – Inter Vlan + VTP

screenshot

– Konfigurasi di sisi User
-PC1
ip 192.168.10.5/24 192.168.10.1
save

-PC2
ip 192.168.20.5/24 192.168.20.1
save

-PC3
ip 192.168.13.5/24 192.168.30.1
save

-PC4
ip 192.168.10.10/24 192.168.10.1
save

-PC5
ip 192.168.20.10/24 192.168.20.1
save

-PC6
ip 192.168.30.10/24 192.168.30.1
save

-PC7
ip 192.168.100.10/24 192.168.100.1
save

-PC8
ip 192.168.100.20/24 192.168.100.1
save

-PC9
ip 192.168.100.30/24 192.168.100.1
save

==============================================================================

-SW1
ESW1#conf t
ESW1(config)#interface range fa1/0 – 2
ESW1(config-if-range)#switchport mode trunk

ESW1(config)#interface fa1/15
ESW1(config-if)#switchport mode trunk
ESW1(config-if)#exit

ESW1#vlan database
ESW1(vlan)#vtp mode server
Setting device to VTP CLIENT mode.
ESW1(vlan)#vtp domain skylab
Changing VTP domain name from NULL to skylab
ESW1(vlan)#vtp password skylab123
Setting device VLAN database password to skylab123.
ESW1(vlan)#vlan 10 name IT
VLAN 10 added:
Name: IT
ESW1(vlan)#vlan 20 name HR
VLAN 20 added:
Name: HR
ESW1(vlan)#vlan 30 name GA
VLAN 30 added:
Name: GA
ESW1(vlan)#vlan 100 name NOC
VLAN 100 added:
Name: NOC
ESW1(vlan)#apply
APPLY completed.

-TSHOOT
ESW1#sh int trunk
ESW1#sh vlan-switch
ESW1#sh int status | in trunk

-SW2
ESW2#vlan database
ESW2(vlan)#vtp client
Setting device to VTP CLIENT mode.
ESW2(vlan)#vtp domain skylab
Changing VTP domain name from NULL to skylab
ESW2(vlan)#vtp password skylab123
Setting device VLAN database password to skylab123.
ESW2(vlan)#exit

ESW2(config)#int fa1/0
ESW2(config-if)#no shut
ESW2(config-if)#switchport mode trunk
*Mar  1 00:03:04.271: %DTP-5-TRUNKPORTON: Port Fa1/0 has become dot1q trunk
ESW2(config)#exit
ESW2#sh vlan-sw

ESW2(config)#int range fa1/10 – 12
ESW2(config-if-range)#no shut
ESW2(config-if-range)#switchport mode access
ESW2(config-if-range)#switchport access vlan 100
ESW2(config-if-range)#exit

-TSHOOT
ESW2#sh int trunk
ESW2#sh vlan-switch
ESW2#sh int fa1/10 switchport
ESW2#sh int status | in trunk

-SW3
ESW3#vlan database
ESW3(vlan)#vtp client
Setting device to VTP CLIENT mode.
ESW3(vlan)#vtp domain skylab
Changing VTP domain name from NULL to skylab
ESW3(vlan)#vtp password skylab123
Setting device VLAN database password to skylab123.
ESW3(vlan)#exit

ESW3#conf t
ESW3(config)#interface fa1/0
ESW3(config-if)#switchport mode trunk
ESW3(config-if)#exit

ESW3(config)#interface fa1/10
ESW3(config-if)#switchport mode access
ESW3(config-if)#switchport access vlan 10
ESW3(config-if)#exit

ESW3(config)#interface fa1/11
ESW3(config-if)#switchport mode access
ESW3(config-if)#switchport access vlan 20
ESW3(config-if)#exit

ESW3(config)#interface fa1/12
ESW3(config-if)#switchport mode access
ESW3(config-if)#switchport access vlan 30
ESW3(config-if)#exit

-THSOOT
ESW3(config-if)#do sh int status

-SW4
ESW4#vlan database
ESW4(vlan)#vtp client
Setting device to VTP CLIENT mode.
ESW4(vlan)#vtp domain skylab
Changing VTP domain name from NULL to skylab
ESW4(vlan)#vtp password skylab123
Setting device VLAN database password to skylab123.
ESW4(vlan)#exit

ESW4#conf t
ESW4(config)#interface fa1/0
ESW4(config-if)#switchport mode trunk
ESW4(config-if)#exit

ESW4(config)#interface fa1/10
ESW4(config-if)#switchport mode access
ESW4(config-if)#switchport access vlan 10
ESW4(config-if)#exit

ESW4(config)#interface fa1/11
ESW4(config-if)#switchport mode access
ESW4(config-if)#switchport access vlan 20
ESW4(config-if)#exit

ESW4(config)#interface fa1/12
ESW4(config-if)#switchport mode access
ESW4(config-if)#switchport access vlan 30
ESW4(config-if)#exit

– ROUTER 1 –
R1#conf t
R1(config)#interface fa0/0
R1(config-if)#no shut

R1(config-if)#interface fa0/0.10
R1(config-subif)#encapsulation dot1Q 10
R1(config-subif)#ip address 192.168.10.1 255.255.255.0
R1(config-subif)#no shut

R1(config-if)#interface fa0/0.20
R1(config-subif)#encapsulation dot1Q 20
R1(config-subif)#ip address 192.168.20.1 255.255.255.0
R1(config-subif)#no shut

R1(config-if)#interface fa0/0.30
R1(config-subif)#encapsulation dot1Q 30
R1(config-subif)#ip address 192.168.30.1 255.255.255.0
R1(config-subif)#no shut

R1(config-if)#interface fa0/0.100
R1(config-subif)#encapsulation dot1Q 100
R1(config-subif)#ip address 192.168.100.1 255.255.255.0
R1(config-subif)#no shut

-done-
Roy.

Menambahkan tanggal dan waktu pada bash history linux

Dalam keadaan standard, pada umumnya ketika kita melihat bash history hanya terdapat daftar2 command yang pernah kita jalankan sebelumnya.. Informasi ini sangat berguna sekali jika sewaktu2 kita lupa akan suatu command. Pada tips n trik kali ini saya mencoba untuk memodifikasi daftar history tersebut dengan menambahkan “Tanggal” dan “Waktu” comand tersebut dijalankan. Sehingga kita dapat mengetahui kapan kita terakhir kali menjalankan command tersebut.

Cara yang dilakukan cukup sederhana, Anda hanya perlu menambahkan 2 baris perintah berikut:

HISTTIMEFORMAT='%F %T '
export HISTTIMEFORMAT
  • Buka file profile yang berada pada direktori /etc

#vim /etc/profile

  • Tambahkan 2 baris perintah tersebut dimana saja,. taruh dibaris paling akhir juga gpp 🙂
  • Logout dan Login Lagi
  • Jalankan perintah #history
Before

Before

After

  • Mudah kan? 🙂